تکنولوژی

WhatsApp به زودی پشتیبانی از iOS 11 و آیفون های قدیمی تر را متوقف می کند



به عنوان بخشی از فرآیند توسعه مستمر، توسعه دهندگان به تدریج پشتیبانی از سیستم عامل های قدیمی را متوقف می کنند. واتس اپ اکنون قصد دارد پشتیبانی از iOS 11 و نسخه های قدیمی تر از سیستم عامل اپل را از 24 اکتبر (2 نوامبر) متوقف کند. با این حال، واتس‌اپ روی آیفون‌هایی که از iOS 12 یا بالاتر پشتیبانی نمی‌کنند کار نخواهد کرد. بنابراین اگر آیفون 5s یا دستگاه های جدیدتری دارید، پس از نصب iOS 12 همچنان می توانید از واتس اپ استفاده کنید. از آنجایی که برنامه ها معمولاً به دلایل مختلف این کار را انجام می دهند، این تصمیم توسط متا به عنوان صاحب واتس اپ گرفته شد. جای تعجب نیست. همچنین نسخه بتا iOS 16 قبلاً منتشر شده است، بنابراین منطقی به نظر می رسد که iOS 11 در این مرحله یک سیستم عامل قدیمی در نظر گرفته شود.بنابراین اگر گوشی قدیمی دارید که از برنامه WhatsApp استفاده می کنید، باید به فکر تغییر آن باشید. تلفن یا سیستم عامل سیستم در دستگاه خود ادامه دهید (در صورت امکان) چرا WhatsApp پشتیبانی از این سیستم عامل را متوقف می کند؟ توسعه دهندگان به چند دلیل معتبر از برنامه های خود در سیستم عامل های قدیمی پشتیبانی نمی کنند. مهمترین دلیل این است که مدیریت پایه کد در دستگاه های قدیمی بسیار دشوار است. از آنجایی که کیت های توسعه نرم افزار جدید (SDK) برای توسعه برنامه ها استفاده می شود، نوشتن کد برای نسخه های قدیمی مشکل است.دلیل دیگر امنیت سیستم عامل های قدیمی و کدهای نوشته شده برای آنهاست. علاوه بر این، سیستم عامل جدید مجموعه ای از ویژگی های پیشرفته را ارائه می دهد که می تواند در طراحی و بهبود برنامه ها مفید باشد. علی‌رغم این موارد، واتس‌اپ و سایر شرکت‌های توسعه اپلیکیشن پشتیبانی از سیستم‌عامل‌های بسیار قدیمی را کنار می‌گذارند. واتس اپ در اوایل سال جاری از ویژگی جدیدی به نام Communities به عنوان آزمایشی رونمایی کرده بود که ویژگی های جدیدی را در اختیار مدیران گروه قرار می دهد. به تازگی این سرویس پیام رسان اعلام کرده است که این قابلیت برای کاربران بیشتری عرضه شده است.

Leave a Reply

نشانی ایمیل شما منتشر نخواهد شد.